Notion Answers

Help between Notion users

Register & Ask

It's free & easy

Get answers

Answers, votes & comments

Vote and select answers

Receive points, vote and give the solution



Can't paste or upload images to Notion pages

Good day all,

I consider myself to be an advanced Notion user apart from being an IT professional and can therefore assure you that I have tried, at least, all the basic remedies, but can for some reason, since yesterday, 10 Sep, not upload or paste new images to any pages.

I mainly use the Desktop version, but have tried this on the website version too. The images are relatively small, eg. 75KB (a far cry from the 5MB limit).

I have also tested this by creating a brand-new page, but still no luck.

I usually take screenshots, and simply Ctrl + V (on Windows) paste them into a Notion page, at which stage the image appears on the page and in the bottom right-hand corner also appears a small indicator showing the upload progress counting down in percentage. As matters stand now, this upload % remains 0 and after a short while in the place where the image should be, appears an info bar indicating that I can upload media eg. pdf, images etc...

Also when using the "/image" shortcut and choosing an image file from my computer, the result is failure, drag & drop also results in failure.

My internet works flawlessly, trying multiple browsers (with caches flushed) have the same outcome, using a second backup internet service provider (completely unrelated to the 1st one) have the same outcome, no security software configurations are interfering with the uploads and I can copy & paste into all sorts of online services eg gMail and as stated both desktop and web versions both fail too. Nothing has changed on my systems.

Has or is anyone experiencing the same phenomenon, or perhaps can direct me to some nuance I can check to get this sorted?

Kind regards,


2 Answers


DigitalNomad Points250

Hey all, just putting this here in case someone runs into something similar.

It took some digging, but I found the cause. The short version is that remnants of Proton VPN, which I installed a couple of months ago, and also uninstalled the same day, did not uninstall completely clean and for some reason two days ago, started to interfere with certain network services. I have now completely cleansed the PC from Proton VPN, and all is good again - Yay :-)


polle commented

Thank you for sharing the cause and the solution, for sure it will help other with the same Notion problem. Please select the answer to mark the question as solved.


mateomiguelo Points140


My answer might seem to be strange, but it has worked for me. I'm using notion among others to learn and everything was fine. Ctrl + V worked very well, but suddenly stops. I checked many sites to solve the issue, but nothing helps. I tried to reinstall notion, reboot windows and still nothing.

I was resinged and I've just hit CTRL + X in some Notion page on my windows desktop app. What I've seen was strange, because many screenshots shows I made today. After this spontanic action, everything is started to work again.

Good luck.

Please log in or register to answer this question.


Welcome to Notion Answers, where you can ask questions and receive answers from other members of the community.

Please share to grow the Notion Community!